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2 Disclaimer 

The actual version of this product (document) is available as is. TEC-IT declines all warranties 
which go beyond applicable rights. The licensee (or reader) bears all risks that might take place 
during the use of the system (the documentation). TEC-IT and its contractual partners cannot be 
penalized for direct and indirect damages or losses (this includes non-restrictive, damages through 
loss of revenues, constriction in the exercise of business, loss of business information or any kind of 
commercial loss), which is caused by use or inability to use the product (documentation), although 
the possibility of such damage was pointed out by TEC-IT.  

 

 
We reserve all rights to this document and the information contained therein. Reproduction, 
use or disclosure to third parties without express authority is strictly forbidden. 
 

 
Für dieses Dokument und den darin dargestellten Gegenstand behalten wir uns alle Rechte 
vor. Vervielfältigung, Bekanntgabe an Dritte oder Verwendung außerhalb des vereinbarten 
Zweckes sind nicht gestattet. 
 

© 1998-2009  
TEC-IT Datenverarbeitung GmbH  
Wagnerstr. 6 

A-4400 Austria  
t.: +43 (0)7252 72720  
f.: +43 (0)7252 72720 77  
http://www.tec-it.com 
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3 Introduction 

3.1 TFORMer  

The TFORMer product family represents a complete, lean and powerful solution for generating 
arbitrary documents. It combines the features of barcode labeling tools with the characteristics of 
report generators into a unified printing-solution. It provides professional layout and output capa-
bilities, an integrated barcode generator, full-featured UNICODE support and it supports direct PDF 
generation. 

3.2 Areas of Application for TFORMer SDK 

TFORMer SDK provides the core output functionality of the TFORMer product family. It can be 
used on client and on server side and it is available for all major operating systems. It can be em-
bedded in your own applications easily. Due to the support of multiple output formats TFORMer 
SDK has a wide field of applications: 

► Reporting Engine  
For software developers the combination of TFORMer SDK and TFORMer Designer 
provides a generic reporting solution which enables end-customers to create and to edit 
form layouts. 

► PDF Library   
TFORMer SDK creates high-quality PDF documents based on graphical layouts. 

► Industrial Printing  
The built-in barcode support satisfies almost all industry labeling requirements. 

► Client- or Server based Reporting  
When it comes to web applications TFORMer SDK reduces round-trips and bandwidth 
requirements. Direct printing or PDF generation from within Microsoft

®
 Internet Explorer is 

supported. 

► Pre-Press and Print-Shop Applications  
Mass-mailings and serial letters are created and printed within minutes. 

3.3 This Document 

The target audience of this document are software developers and system administrators. The in-
formation in this document provides a high-level introduction regarding the supported operating sys-
tems and the available APIs (Application programming Interfaces) of TFORMer SDK. 

For detailed information regarding programming TFORMer SDK we recommend to check out these 
additional documents:  

 TFORMer SDK – DLL Programming Reference 
This document describes the DLL API (Windows) as wells as the shared library API (Linux). 

 TFORMer SDK – COM Programming Reference 
This document describes the COM programming interface.  

 TFORMer SDK – .NET Programming Reference 
This document describes the .NET programming interface. 

 TFORMer Designer User Manual 
This document provides an in-depth documentation of the graphical layout editor.  
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4 Highlights of TFORMer SDK 

4.1 Unified Output Solution 

TFORMer SDK unifies output tasks. A specific form layout produces identical output across printer 
models, operating systems and output formats. Supported output formats are: 

 Direct Printing 
Print layouts directly on all printers supported by Microsoft

®
 Windows. 

 PDF 
PDF export with full-featured barcode support, Unicode and font embedding.  

 PostScript
®
  

Used for printing under Linux/UNIX and for pre-press applications. 

 HTML
1
  

The built-in HTML output is ideal for previewing and for web-based applications. 

 Image Formats  
The built-in image output supports BMP, GIF, JPG, PCX, TGA, PNG and TIF formats 
(including multipage TIF). 

 ZEBRA
®
  

Print to ZEBRA
®
 printers without any additional driver. ZPL-II output is generated directly. 

 ASCII  
Pure ASCII output without any graphics for special purpose requirements. 

4.2 UNICODE Support 

The integrated UNICODE support allows you to use TFORMer SDK with almost any established 
language. 

4.3 Barcode Support  

TFORMer SDK offers integrated support for all linear, 2D and composite barcodes in common use.  

4.4 Reusable, Smart Form Layouts 

TFORMer SDK separates form layouts from the underlying data. It does not bind form layouts to 
certain printer models or databases. The output is dynamically controlled by means of layout 
properties, conditional printing, tray control and individual computations. 

4.5 Cross Platform 

TFORMer SDK was designed to cover all operating systems in common use. It is available for 
Microsoft

®
 Windows and for major Linux

®
/UNIX

®
 variants. 

4.6 Small Footprint, High Performance 

TFORMer SDK provides high performance PDF and printer output in combination with very low 
system requirements (only 20 MB hard-disc space required on Microsoft

®
 Windows).  

                                                      
 
 
1
 Due to the nature of HTML some output features may be limited or not available. 
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5 Installation on Microsoft Windows 

5.1 Introduction 

This chapter describes the installation of TFORMer SDK on Microsoft
®
 Windows. The setup 

application comes as MSI file (Microsoft
®
 Windows Installer). MSI setups can be installed without 

any additional tool on Windows Vista
®
, on Windows Server 2003, on Windows XP, and on Windows 

2000. MSI 2.0 or higher is required. 

The TFORMer SDK core components do not rely on .NET 2.0 but TFORMer SDK ships with 
some .NET based components like a .NET assembly, sample applications and TFORMer 
QuickPrint. If you are interested in these features install the .NET 2.0 runtime before installing 
TFORMer SDK. 

5.2 General 

On Microsoft
®
 Windows the installation of TFORMer SDK is straight-forward. The MSI setup 

application will install the TFORMer SDK components, sample applications and documentation. 

The default installation path is: 

C:\Program Files\TEC-IT\TFORMer6 SDK 

5.3 Sample Applications 

On Windows Vista all sample applications and layout templates are installed in the following 
directory (please note that Windows Explorer does not display the folder ProgramData by default, 
you need to enable Show hidden files and folders in the Folder and Search options): 

C:\ProgramData\TEC-IT\TFORMer\6.0 

All other versions of Microsoft
®
 Windows use the following directory for sample applications and 

templates: 

C:\Documents and Settings\All Users\Application Data\TEC-IT\TFORMer\6.0 

5.4 Supported APIs 

After installation the functionality of TFORMer SDK is available via the following APIs: 

► COM Component   
This API is available via the file TFORMerCOM60.dll. The COM component is registered 
automatically by the setup application.  

► .NET Component  
The file TECIT.TFORMer.dll provides the .NET functionality. .NET 2.0 or higher is required. 
The .NET assembly is automatically installed in the GAC. 

► DLL  
TFormer60.dll is a 32-bit Windows DLL. The corresponding library and include files are 
named TFormer60.lib and TFormer6.h. For Linux and UNIX a shared library with an identical 
API is available. For details, please refer to chapter 6. 
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► Command Line Application  
The command-line based executable is named tfprint.exe. The command line application is 
also available for Linux and UNIX. For details, please refer to chapter 6. 

► JAVA  
The JAVA API can be integrated in J2EE architectures (web applications or web services) 
and GUI applications (e.g. Swing, AWT). 
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6 Installation on Linux
®
 or UNIX

®
 

6.1 Introduction 

This chapter describes the installation of TFORMer SDK on Linux
®
 and UNIX

® 
based operating 

systems. Depending on the operating system TFORMer SDK is available as rpm or tarball. For 
details, please refer to section 6.5. 

► Please note that the graphical design tool TFORMer Designer is only available for 
Microsoft

®
 Windows. 

6.2 General 

The default installation path of TFORMer SDK is 

/usr/local/ 

The TFORMer SDK Command Line Application tfprint is installed into 

/usr/local/bin/tfprint 

All configuration files, the license file tfprint.ini and some sample applications are located in the 
following directory: 

/usr/local/share/TFORMer/ 

This directory contains the following subdirectories: 

 Templates: conatins ready-to-use layout templates designed with TFORMer Designer. 

 Demo: Repository contains a sample repository. The forms contained in this repository are 
used by sample applications.  

 Demos: contains sample shell scripts which demonstrate the use of tfprint (see chapter 12). 

 SampleCode: see section 6.3! 

 SampleCodeCGI: see section 6.3! 

 SampleCodeNet: see section 6.3! 

The include files needed for software development are stored in: 

/usr/local/include/ 

/usr/local/include/TECITSTd/ 

The developer documentation is available by opening index.html with your browser in: 

/usr/local/share/TFORMer/APIDocs 

Additional documentation is available through a man page. 

$ man tfprint 

6.3 Sample Applications 

The directory 

/usr/local/share/TFORMer/ 

contains the following subdirectories with sample applications: 
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 SampleCode 
This sample is written in C (TFORMerSimpleX.c). It generates barcode labels as a PDF-
Document. 

 SampleCodeCGI 
This web-based PHP CGI sample creates PDF files from user supplied data using tfprint. 

 SampleCodeNet 
This sample demonstrates the use of the C# DLL with Mono. It generates barcode labels as 
a PDF-Document. Please note: This sample requires the TECIT.TFORMer.dll. 

6.4 Supported APIs 

After installation the functionality of TFORMer SDK is available via the following APIs: 

► Shared Library  
named libTFORMer6.so or libTFORMer6.a. The interface of the shared library is 100% com-
patible with the DLL API on Microsoft

®
 Windows.  

► Command Line Application  
The command-line based executable is named tfprint 

6.5 Platform specific Installation Hints 

6.5.1 Linux
®
 (deb- or rpm-based) 

The listed Linux distributions are supported with ready-to-run binaries. Whenever possible, other 
platforms are provided on request.  

 SuSE Linux 10.2 on i586 

 SuSE Linux Enterprise 9 on i586 

 RedHat Enterprise 5 on i586 

 RedHat Fedora Core 6 on i586 

 Ubuntu 7.04 on i586 

6.5.1.1 Dependencies 

Before installing TFORMer SDK make sure to check if the following packages are available: 

fontconfig-2.2.9 

freetype2-2.1.7 

libxml2-2.6.7 

libxslt-1.1.14 

cups-1.1.20 (or later) 

unixODBC-2.2.11 (optional; only required if SQL is used) 

6.5.1.2 Rpm Installation 

Install the executables for TFORMer SDK (which also include some sample applications) with the 
following command (as root-user) within the shell: 

$ su  
$ sh TFORMer-6.0.0-1.i586.rpm.bin 

After confirming the license agreement with yes this script installs the rpm. After the installation you 
will be asked if you want to generate a demo-report. 
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1.1.1.1 Rpm De-Installation 

TFORMer SDK can be de-installed using the commands below: 

$ su  
$ rpm -e TFORMer 

6.5.1.3 Deb (Debian) Installation 

Install the executables for TFORMer SDK including some sample applications with the following 
command (as root-user) within the shell: 

$ sudo su   
$ sh TFORMer-6.0.0-1-i386.deb.bin 

After confirming the license agreement with yes this script installs the rpm. After the installation you 
will be asked if you want to generate a demo-report. 

1.1.1.2 Deb (Debian) De-Installation 

TFORMer SDK can be de-installed using the commands below: 

$ sudo su   
$ dpkg -r TFORMer 

6.5.2 HP-UX
® 

(tarball)  

The listed platforms are supported with ready-to-run binaries. Whenever possible, binaries for other 
platforms are provided on request. 

 HP-UX 11i v2 (B.11.23) on IA64 (Itanium-2 Architecture) 

 HP-UX 11 (11.00) on PA-RISC 2.0 

6.5.2.1 Dependencies  

Before installing TFORMer SDK make sure to check if the following packages are available: 

freetype-2.1.10-ia64-11.23.depot        

libxml2-2.6.23-ia64-11.23.depot 

gettext-0.14.5-ia64-11.23.depot         

libxslt-1.1.15-ia64-11.23.depot 

expat-1.95.8-ia64-11.23.depot           

lcms-1.15-ia64-11.23.depot.gz           

zlib-1.2.3-ia64-11.23.depot 

fontconfig-2.3.2-ia64-11.23.depot       

libiconv-1.10-ia64-11.23.depot 

A good place for downloading precompiled packages is: http://hpux.connect.org.uk/ 

6.5.2.2 Installation 

TFORMer SDK installation is straight forward. TFORMer is distributed as tarball which includes an 
install script. 

$ gunzip SetupTFORMer-6.0.0-HPUX11.23-IA64.tar.gz  
$ tar xf SetupTFORMer-6.0.0-HPUX11.23-IA64.tar  
$ cd SetupTFORMer  
$ sh install.sh 

After confirming the license agreement with yes this script installs TFORMer. After the installation 
you will be asked if you want to generate a demo-report. 
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6.5.3 AIX
® 

(tarball) 

The listed platforms are supported with ready-to-run binaries. Whenever possible, binaries for other 
platforms are provided on request. 

 AIX 4.3 PPC 

 AIX 6.1 PPC (P6) 

6.5.3.1 Dependencies  

Before installing TFORMer SDK make sure to check if the following packages are available: 

► Installation of the RPM Package Manager is a must! 

AIX 5.x, AIX 6.1 

rpm.rte.3.0.5.30 

fontconfig-2.2.2-3.aix5.1.ppc.rpm 

freetype2-2.1.7-2.aix5.1.ppc.rpm 

libxml2-2.6.21-4.aix5.2.ppc.rpm 

zlib-1.2.2-4.aix5.1.ppc.rpm 

libart_lgpl-2.3.17-4.aix5.1.ppc.rpm 

libxslt-1.1.5-2.aix5.1.ppc.rpm 

It is necessary to extract some libraries from their archives and create symbolic links: 

cd /opt/freeware/lib 

# extract shared library and create a link 

ar -x libfreetype.a 

ln -sf libfreetype.so.6 libfreetype.so 

 

# extract shared library and create a link 

ar -x libart_lgpl_2.a 

ln -sf libart_lgpl_2.so.2 libart_lgpl_2.so 

AIX 4.3 

rpm.rte.3.0.5.30 

fontconfig-2.2.0-1.aix4.3.ppc.rpm 

freetype2-2.1.5-1.aix4.3.ppc.rpm 

libxml2-2.6.20-1.aix4.3.ppc.rpm 

zlib-1.1.4-3.aix4.3.ppc.rpm 

Good places for downloading precompiled packages are: 

 http://www-03.ibm.com/servers/aix/products/aixos/linux/download.html 

 ftp://ftp.software.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc 

6.5.3.2 Installation 

The installation is identical to HP-UX (see section 6.5.2.2). 

6.5.4 Solaris
® 

(tarball) 

The listed platforms are supported with ready-to-run binaries. Whenever possible, binaries for other 
platforms are provided on request. 

 Solaris 10 x86 

6.5.4.1 Dependencies  

Before installing TFORMer SDK make sure to check if the following packages are available: 

freetype-2.3.1-sol10-x86-local.gz 

fontconfig-2.4.2-sol10-x86-local.gz 
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6.5.4.2 Installation 

To install TFORMer 6.0 for Solaris 10 perform the following steps: 

gunzip TFORMer-6.0.0-solaris10.x86.tar.gz  

cp TFORMer-6.0.0-solaris10.x86.tar / 

cd / 

tar xvf TFORMer-6.0.0-solaris10.x86.tar 

 TFORMer is now installed in /usr/local/bin/ 

 The configuration file and documentation can be found in /usr/local/share/TFORMer 

 You should now be able to print a demo PDF by executing: 
/usr/local/share/TFORMer/Demos/DemoBarcodeLabels.sh 
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7 COM Component 

7.1 Introduction 

COM components (Component Object Model) are software components which can be integrated 
seamlessly into other software products or used with development environments like: 

 Visual
®
 Basic

®
, Visual C++, Visual Studio .NET, Visual Studio 2008, Borland C++ Builder, 

Borland Delphi, …  

 Microsoft
®
 Office product suite (in conjunction with Visual Basic for Applications – VBA) 

 HTML pages on client- or server-side (ASP, ASP . NET, VBScript, …) 

 Command-line based scripting environments (Visual Basic Scripting Host) 

 

► Please note: COM technology is only available on Microsoft
®
 Windows. 

7.2 Outline 

► The name of the type library is TFORMer 6.0 Runtime Type Library.  
The GUID is 32570E68-5DA0-4C6B-9A19-ADB1E21B3A88. 

► The Class ID of the COM Control is 18D87050-AAC9-4E1A-AFF2-9D2304F88F7C. 

The general steps for using the COM based API of TFORMer SDK are: 

1. Embed the TFORMer COM component into your application or document. Usually this is 
done by establishing a reference to the “TFORMer 6.0 Runtime Type Library”. 

2. Create an instance of the “TFORMer60Lib.TFORMer” COM class 

3. Create a job-instance. 

4. Create a datasource instance and connect the job with the datasource. 

5. Set the properties of the job object (e.g. name of the form layout, output type and printer 
name).  

6. Provide or import the values for data fields via the datasource object. 

7. Finally call the Print method. 

The general VBA-code for using TFORMer SDK looks as follows: 

' This code snippet demonstrates the basic steps for using the TFORMer SDK - COM component 

from within VBA. Take care to establish a reference to TFORMer 6.0 Runtime Type Library 

beforehand! 

Private Sub TFORMer_Output() 

   ' Declare the variables 

   Dim TFormer 

   Dim PrintJob 

   Dim DataSource As TFORMer60Lib.IDataSourceRecordSet 

   ' create a TFORMer Runtime instance 

   Set TFormer = CreateObject("TFORMer60Lib.TFormer") 

   ' create a job object with TFORMer 

   Set PrintJob = TFormer.CreateJob 

   ' create (and connect) a data source for providing datafields values 
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   Set DataSource = printjob.NewDataSourceRecordSet 

   ' select the form layout to be printed/generated, select type and name of the output 

   PrintJob.RepositoryName = "FILENAME_OF_YOUR_FORMLAYOUT.tff" 

   PrintJob.OutputName = "C:\temp\output.pdf" 

   PrintJob.PrinterType = TECIT.TFORMer.PrinterType.PdfFile 

 

   ' provide data for the datafields used in the form layout 

   DataSource.AddNewRecord 

   DataSource.SetDataField "NAME_OF_YOUR_DATAFIELD", "This is the value of the datafield" 

   ' Finally print the form layout 

   printjob.PrintForm 

End Sub 

7.3 Using the COM Object in Development Environments 

7.3.1 Microsoft Visual Basic 6 

1. Open or create your Visual Basic Project. 

2. Choose Project ► References from the menu. 

3. Choose TFORMer 6.0 Runtime Type Library from the list, select the entry and click OK. 

4. Now you can use the COM based API of TFORMer SDK in your program. 

7.3.2 Microsoft Visual C/C++ 6 

1. Open and create your MFC application (e.g. by using the MFC App Wizard). Make sure that 
Enable Automation is adjusted in your project. 

2. Choose menu View ► ClassWizard to enter the Class Wizard. 

3. Choose the button Add Class ► From a type library and select TFORMerCOM60.dll from 
the installation path of TFORMer (Bin subdirectory). 

4. Now the type library is read from this DLL and the implemented classes (IJob, 
IDataSourceRecordSet…) are displayed in the Confirm Classes dialog.  

5. Proceed with OK. 

6. After this step you can see the new TFORMer COM classes in the ClassView. 

7. Include the generated header file tformercom60.h into your cpp file. 

8. TFORMer SDK may now be used in your MFC application. 

7.3.3 Other development Environments 

Please refer to the documentation of your development environment. 

7.4 Site Locking in MS-IE 

Using the TFORMer SDK COM component within Microsoft
®
 Internet Explorer is restricted by “Site 

Locking”. This prevents potentially harmful websites from damaging your local system, e.g. by over-
writing system files on your local hard drive. 

Site Lock restricts the use of an ActiveX control to a predetermined list of domain names or security 
zones. As long as a specific domain or protocol is not unlocked in the registry, the TFORMer COM 
component cannot be used within Microsoft

®
 Internet Explorer. 

► For details please refer to the TFORMer SDK Developer Reference (see section 
Introduction: Security). 
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7.5 More Information 

For more information, please check out the following documents and sample applications: 

 COM Programming Reference  
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ►Documentation ► COM 
Programming Reference. 

 Sample Microsoft
®
 Excel Spreadsheet using TFORMer SDK 

Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ► Examples ► Microsoft Office. 
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8 .NET Component 

8.1 Introduction 

The TFORMer SDK .NET component is perfect suited for application development with any .NET 
programming language (or Mono on Linux/UNIX). 

 On Microsoft
®
 Windows the setup application installs the TFORMer assembly automatically 

in the GAC (Global Assembly Cache) and in the Bin subdirectory of the TFORMer SDK 
default installation path. The .NET classes can be used immediately with development 
environments like Microsoft

®
 Visual Studio. 

 On Linux the setup scripts are installing the suitable Mono-bindings automatically. 

 

► On Microsoft
®
 Windows the TFORMer SDK .NET component requires .NET 2.0 or higher. 

► On Linux/UNIX TFORMer SDK for .NET works with Mono 1.2.3 or higher (Mono is the open 
source equivalent for .NET).  

8.2 Outline 

► When establishing a reference the name of the .NET component is TFORMer 6.0 Runtime 
(file TECIT.TFORMer.dll). 

The general steps for using the TFORMer SDK .NET assembly are: 

1. Establish a reference to TFORMer 6.0 Runtime. 

2. Depending on the programming language include the TECIT.TFORMer namespace. 

3. Create a job-instance (TECIT.TFORMer.Job).  

4. Create a datasource instance (TECIT.TFORMer.DataSource or derived classes). 

5. Connect the job with the datasource. 

6. Set the properties of the job to the required values (e.g. name of the form layout, output type 
and printer name).  

7. Provide or import the values for data fields via the datasource. 

8. Finally generate the required output with the Print method. 

The general code for using TFORMer SDK in Visual Basic .NET looks as follows: 

' This code snippet demonstrates the basic steps for using the TFORMer SDK - from within  

' VB .NET. Take care to establish a reference to TFORMer 6.0 Runtime from within your  

' project! 

Private Sub TFORMer_Output () 

  ' Declare the variables 

  Dim job As TECIT.TFORMer.Job 

  Dim datasource As TECIT.TFORMer.DataSourceRecordSet 

  ' create objects for a job and a datasource 

  job = New TECIT.TFORMer.Job 

  datasource = New TECIT.TFORMer.DataSourceRecordSet 

  ' connect the datasource with the job 

  job.DataSource = datasource 

  ' select the form layout to be printed/generated, adjust the type and name of the output 
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  job.RepositoryName = "FILENAME_OF_YOUR_FORMLAYOUT.tff" 

  job.OutputName = "C:\temp\output.pdf" 

  job.PrinterType = TECIT.TFORMer.PrinterType.PdfFile 

  ' provide data for the datafields used in the form layout 

  Dim record As TECIT.TFORMer.Record 

  record = New TECIT.TFORMer.Record 

  record.Data.Add "NAME_OF_YOUR_DATAFIELD", "This is the value of the datafield") 

  datasource.Records.Add(record) 

  ' finally print it 

  job.Print() 

         

End Sub 

8.3 More Information 

For more information, please check out the following documents and sample applications: 

 NET Programming Reference  
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ►Documentation ► NET 
Programming Reference 

 Sample Code 
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ► Examples ► Programming 
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9 DLL (Dynamic Link Library) 

9.1 Introduction 

Besides the COM and .NET Interface, the TFORMer SDK contains also a Microsoft
®
 Windows DLL 

(32 bit/64 bit). A DLL is a library, which offers its functionality via a documented interface. DLLs can 
be used in  

 Most programming languages and development environments (e.g.: Visual C/C++,.NET, All 
versions of Visual Studio, Visual Basic, Borland C++ Builder, Borland Delphi, …)  

 Web-based scripting languages like PHP 

 

► Please note: The DLL is only available on Microsoft
®
 Windows. If you need to use a DLL-like 

interface on Linux/UNIX please use the shared library (see chapter 10). 

9.2 Compiling your Own Applications 

The files TFormer60.lib (library) and TFormer6.h (header file) are required to compile and link your 
own applications with the TFORMer DLL. These files are usually stored in the following folder: 

C:\Program Files\TEC-IT\TFORMer6\Bin 

Make sure the compiler and the linker are able to locate these files. 

9.3 Outline 

The general steps for using the TFORMer DLL are: 

1. Include TFormer6.h. Make sure to define  TECIT_DLLIMPORT before including the header 
file. 

2. Initialize the TFORMer DLL and save the handle (TFormer_Init). 

3. Select the form layout to be printed (TFormer_SetRepositoryName). 

4. Select the type of the output and the target file or device (TFormer_SetPrinterName). 

5. Provide values for datafields (if any) in the form layout. 

6. Generate or print the output (TFormer_Print). 

7. De-initialize TFORMer SDK (TFormer_Exit). 

The general C-code for using TFORMer DLL looks as follows: 

// This is not a complete application. It is just a sample without any error handling  

// to demonstrate the basic steps for using the DLL interface 

// 

// define TECIT_DLLIMPORT before including TFormer6.h!  

#define  TECIT_DLLIMPORT     

#include "PATH_TO_TFORMER/TFormer6.h" 

#undef   TECIT_DLLIMPORT 

// Handle for TFORMer SDK 

HTFORM   hTForm  = NULL; 

// initialize TFORMer SDK 

hTForm = TFormer_Init (NULL); 

/* Select the form to be printed 
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TFormer_SetRepositoryName (hTForm, "FILENAME_OF_YOUR_FORMLAYOUT.tff");      

/* use the default printer of the system */ 

TFormer_SetPrinterName (hTForm, NULL, NULL); 

/* Add a Data record */ 

TFormer_NewRecord (hTForm);   

/* Set a Datafield value */ 

TFormer_SetVarValue (hTForm, "NAME_OF_YOUR_DATAFIELD", "Value of the datafield"); 

/* Start printing */ 

TFormer_Print (hTForm); 

/* Exit TFORMer */ 

TFormer_Exit (hTForm); 

9.4 More Information 

Check out the following documents and sample applications for more information: 

 DLL Programming Reference  
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ►Documentation ► DLL Programming 
Reference. 

 Sample applications with source code  
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ► Examples ► Programming. 

 Appendix B describes how data is provided to TFORMer SDK. 

 Appendix C describes how to adjust general output options. 
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10 Shared Library  

10.1 Introduction 

A shared library on Linux or UNIX is the counterpart to a DLL on Microsoft
®
 Windows. Such a library 

offers its functionality via a documented interface to applications. All programming languages on 
Linux/UNIX are able to use shared libraries.  

► Please note: The shared library is only available on Linux/UNIX. If you need to use a similar 
interface on Microsoft

®
 Windows please use the DLL (see chapter 9). 

10.2 Compiling Your Own Applications 

The following files are required to build your own applications with the shared library: 

 TFormer6.h: This is the include file for the TFORMer SDK shared library API. 

 TECITStd.h: An additional include file for Linux/UNIX. 

 libTFORMer6.so: This is the shared library. 

 libTFORMer6.a: This is the static library version of TFORMer SDK. 

After the shared library of TFORMer SDK has been installed the include files TFormer6.h and 
TECITStd.h are stored in: 

/usr/local/include/ 

/usr/local/include/TECITSTd/ 

Make sure the compiler and the linker are able to locate these files. Compile and link your applicati-
ons with a command similar to the following (see also the shell script build_sample.sh): 

$ gcc TFORMerSimpleX.c -o TFORMerSimpleX -ldl –lTFORMer6 -L/usr/local/lib -I/usr/local/include 

10.3 Outline 

The general steps for using the shared or static library are: 

1. Make sure to define TECIT_DLLIMPORT and _TEC_UNIX and TEC_UNIX_BUILD. 

2. Depending on your platform define TEC_LINUX, TEC_FREEBSD, TEC_AIX, TEC_HPUX, 
TEC_SOLARIS, TEC_OS400 or TEC_SCO. Only one platform is allowed! 

3. Include TECITStd.h and TFormer6.h.  

4. Initialize the TFORMer Shared Library and save the handle (TFormer_Init). 

5. Select the form layout to be printed (TFormer_SetRepositoryName). 

6. Select the type of the output and the target file or device (TFormer_SetPrinterName). 

7. Provide values for datafields (if any) in the form layout. 

8. Generate or print the output (TFormer_Print). 

9. De-initialize the TFORMer Library (TFormer_Exit). 
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The general C-code for using TFORMer SDK looks as follows: 

// This is not a complete application. It is just a sample without any error handling  

// to demonstrate the basic steps for using the DLL interface 

// 

// define TECIT_DLLIMPORT before including TFormer6.h!  

#define TECIT_DLLIMPORT     

/* enable a TFORMer Unix build using the two defines below */ 

#define _TEC_UNIX 

#define TEC_UNIX_BUILD 

/* Set the define for the concrete OS you are using */ 

#define TEC_LINUX 

/* #define TEC_FREEBSD */ 

/* #define TEC_AIX */ 

/* #define TEC_HPUX */ 

/* #define TEC_SOLARIS */ 

/* #define TEC_OS400 */ 

/* #define TEC_SCO */ 

 

/* include the TECITStd header for required defines */ 

#include <TECITStd/TECITStd.h> 

/* include TFORMer6.h */ 

#include <TFormer6.h> 

/* undefine - as they are only required for TFORMer Header files */ 

#undef TECIT_DLLIMPORT 

#undef _TEC_UNIX 

#undef TEC_UNIX_BUILD 

// Handle for TFORMer SDK 

HTFORM   hTForm  = NULL; 

// initialize TFORMer SDK 

hTForm = TFormer_Init (NULL); 

/* Select the form to be printed 

TFormer_SetRepositoryName (hTForm, "FILENAME_OF_YOUR_FORMLAYOUT.tff");      

/* use the CUPS default printer of the system */ 

TFormer_SetPrinterName (hTForm, NULL, NULL); 

/* Add a Data record */ 

TFormer_NewRecord (hTForm);   

/* Set a Datafield value */ 

TFormer_SetVarValue (hTForm, "NAME_OF_YOUR_DATAFIELD", "Value of the datafield"); 

/* Start printing */ 

TFormer_Print (hTForm); 

/* Exit TFORMer */ 

TFormer_Exit (hTForm); 
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10.4 Sample Application 

A sample application which uses the shared library is installed in: 

/usr/local/share/TFORMer/SampleCode 

This C code generates a PDF file with barcode labels. The sample application uses the same docu-
ment layout as the script DemoBarcodeLabels.sh mentioned in section 12.3.2.2. Datafield values 
are passed programmatically.  

Compile it by executing: 

$ gcc TFORMerSimpleX.c -o TFORMerSimpleX -ldl –lTFORMer6 -L/usr/local/lib -I/usr/local/include 

10.5 More Information 

For more information, please check out the following documents and sample applications: 

 DLL Programming Reference  
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ►Documentation ► DLL Programming 
Reference. 

 Sample Applications with source code  
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ► Examples ► Programming. 

 Appendix B describes how data is provided to TFORMer SDK. 

 Appendix C describes how to adjust general output options. 
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11 Java Component 

11.1 Introduction 

The Java component of TFORMer SDK is a software layer between the TFORMer SDK 
(DLL/Shared Library) and the Java Virtual Machine through Java Native Interface (JNI) technology. 
The architecture of this layer is composed by: 

 The library TFORMer60 (DLL or shared library), in order to execute the TFORMer SDK; 

 The JNI library TFORMer60JNI (DLL or shared library), to translate the Java calls to the 
TFORMer Runtime requests and responses; 

 The Java library TFormer60.jar, to simplify the access to the TFORMer SDK. 

In particular, the Java library is built following the .NET architecture in order to maintain a simply 
and uniform program interface. It's important that the paths of the TFORMer SDK – DLL (or shared 
library on UNIX platform) and the JNI library are included into the java.library.path of the Java 
Virtual Machine: so, you must ensure that your system respects one of the following cases: these 
libraries are 

 defined into the environment variable PATH (Windows), LD_LIBRARY_PATH (Linux and 
Macintosh), SHLIB (HPUX) or LIBPATH (AIX); 

 defined into the parameter -Djava.library.path of the java command; 

 defined as system libraries. 

Naturally, the Java library (JTFormer60.jar) must include into the classpath of the javac/java 
command in order to compile and execute your projects. 

11.2 Outline 

The general steps for using the Java component of TFORMer SDK are: 

1. Include the com.tecit.TFORMer and com.tecit.TFORMer.Printing namespaces. 

2. Create a job-instance (com.tecit.TFORMer.Printing.Job). 

3. Create a datasource instance (with the derived classes of 
com.tecit.TFORMer.Printing.JobDataSource). 

4. Connect the job with the datasource. 

5. Use the setter methods of the job to define the required values (e.g. name of the form layout, 
output type and printer name). 

6. Provide or import the values for data fields via the datasource. 

7. Generate the required output with the print method. 

8. Finally free the resources allocated using the dispose method. 

The general Java code for using TFORMer SDK looks as follows: 

// This code snippet demonstrates the basic steps for using the TFORMer SDK from within 

// Java. Take care to include the TFORMer Java library in your project and to include the 

// TFORMer SDK and JNI DLL/shared library into the java.library.path 

import com.tecit.TFORMer.*; 

import com.tecit.TFORMer.Enumerations.*; 

import com.tecit.TFORMer.Printing.JobDataRecordSet; 

import com.tecit.TFORMer.Printing.Job; 

import com.tecit.TFORMer.Printing.JobDataRecordSet.Record; 

 

private void printWithJTFORMer() 

throws TFormerException 

{ 
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 // create objects for a job and a datasource 

 // NOTE: the constructor can generate an exception if the TFORMer SDK is not 

 // accessible (java.library.path doesn't contain the TFORMer DLLs or shared libraries) 

 Job job = new Job(); 

 JobDataRecordSet datasource = new JobDataRecordSet(); 

 

 try { 

  // connect the datasource with the job 

  job.setJobData(datasource); 

 

  // select the form layout to be printed/generated, 

  // adjust the type and name of the output 

 

  job.setRepositoryName("FILENAME_OF_YOUR_FORMLAYOUT.tff"); 

  job.setOutputName("C:\\temp\\output.pdf"); 

  job.setPrinterType(EPrinterType.PSFile); 

 

  // provide data for the datafields used in the form layout 

  Record record = new JobDataRecordSet.Record(); 

  record.setData("NAME_OF_YOUR_DATAFIELD", "This is the value of the datafield"); 

  datasource.add(record); 

  // finally print it 

  job.print() 

 } 

 catch(TFormerException ex) 

 { 

  throw ex; 

 } 

 Finally 

 { 

  // dispose ALWAYS the resources in order to free the TFORMer SDK resources 

  job.dispose(); 

  job = null; 

 } 

} 

► Please note: In order to free the resources allocated by TFORMer SDK, it's important to call 
the method dispose of the JTFormer classes. A use of the TFORMer Java classes without 
the invocation of the method dispose can determine problem of memory allocation. This 
behavior is classic on Java platform, such as in the use of the JDBC classes: an intensive 
use of the SQL statement without closing operations (method close) can determine 
problems on the database. 

11.3 More Information 

For more information, please check out the following documents and sample applications: 

 Java Programming Reference  
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ►Documentation ► Java 
Programming Reference. 

 Sample Code  
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ► Examples ► Programming. 
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12 Command Line Application 

12.1 Introduction 

The TFORMer SDK command line application is available for Microsoft
®
 Windows, Linux and UNIX. 

It generates output based on arbitrary form layouts created with TFORMer Designer.  

The executable is named tfprint (or tfprint.exe on Microsoft
®
 Windows) and can be used  

 on its own (executed manually) 

 as part of batch jobs or shell scripts 

 via “shell-execute” as “out-of-process” reporting engine  

 as extension for printer filter applications on Linux/UNIX 

12.2 Outline 

The general steps for using tfprint are: 

1. Create the required form layouts using TFORMer Designer. 

2. Provide data for the form layouts via XML, CSV, TXT or ODBC datasources.  

3. Embed tfprint into your batch-job, shell script or applications.  

 

► On Microsoft
®
 Windows the files for the form layouts or file-based datasources (XML, CSV or 

TXT) may be provided as a filename (as file stored in the file system) or as http-based URL.  

 

 
Figure 1: tfprint command line parameters  

When using tfprint to generate output you need at least 3 parameter groups: 
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 the form layout (command line parameter –F) 

 the datasource (command line parameters –D, –DT, –DO) 

 the type and target of the generated output (command line parameters –O, –OT, –OO) 

12.3 Samples  

12.3.1 For Microsoft Windows 

In the example below tfprint is used to generate a form layout (MyLayout.tff) using the datasource 
MyValues.txt (a datasource contains values for datafields) as a PDF document named Output.pdf: 

tfprint -F MyLayout.tff  -D "MyValues.txt" -DT TEXT -DO SC, QC\" -O Output.pdf -OT PDF 

Numerous sample applications are installed by the setup application – check out the following menu 
entry for details: 

Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ► Examples ► Command Line Printing 

12.3.2 For LINUX and UNIX 

12.3.2.1 Generate all Templates as PDF 

In order to generate all form layouts stored in the Templates directory as PDF-files execute the 
following script: 

$ sh /usr/local/share/TFORMer/Demos/DemoPDF.sh 

The resulting PDF-files are created in your current working directory. The generated PDF files will 
need about 60 MB of disc space! 

12.3.2.2 Generate Barcode-Labels (PDF-Output) 

This script generates barcode labels as PDF-file: 

$ sh /usr/local/share/TFORMer/Demos/DemoBarcodeLabels.sh 

The layout for the label is stored in the demo repository. The result is created in your current 
working directory. 

12.4 More Information 

For more information, please check out the following documents: 

 Check out the TFPrint User Manual. 
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ►Documentation ► TFORMer V60 
Command Line. 

 Execute tfprint –h to display a detailed description of the command line parameters. On 
Linux/UNIX type man tfprint to display the man-pages. 

 Check out the TFORMer Designer User Manual  
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ►Documentation ► TFORMer V60 
Designer. 

 Appendix B describes how data is provided to TFORMer SDK. 

 Appendix C describes how to adjust general output options. 
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13 TFORMer SDK with Microsoft Office 

13.1 Introduction  

Most applications of the Microsoft
®
 Office Suite are supporting the Component Object Model 

(COM). That means that COM-compliant software components like the TFORMer SDK can be 
embedded and programmed directly as part of documents, spreadsheets, forms or databases. 

The integration of COM components into the Microsoft
®
 Office Suite works completely seamlessly. 

For example the TFORMer SDK can be embedded into Microsoft
®
 Access™ for printing barcode 

labels or generating PDF output.  

Within the Microsoft
®
 Office suite VBA (Visual Basic for Applications) is used as programming 

language. Thus, the functionality of the TFORMer SDK is also accessible via VBA. 

13.2 Hints for different Office-Versions 

This section concentrates on the first steps for integrating the COM component of TFORMer SDK 
into a specific Microsoft

®
 Office product. 

► Depending on the application it may be necessary to switch to “design” or “edit” mode in 
order to create VBA program code.  

► Macros must be activated/enabled (Word, Excel…). 

► The security settings of the container application must be adjusted to allow active content or 
macros. Scripting has to be enabled. 

13.2.1 Microsoft Word/Excel 2007 

1. Open or create your document. 

2. Enable the developer tab in the ribbon (Office Button ► Word/Excel Options ► Show 
Developer tab in the Ribbon). 

3. Activate the Developer tab. 

4. Click Visual Basic to open the Microsoft
®
 Visual Basic editor. 

(Alternatively you can also use the shortcut Alt+F11). 

5. Click Tools ► References and check TFORMer 6.0 Runtime Type Library to insert a 
reference to TFORMer SDK. 

6. Click OK. 

7. TFORMer SDK may now be used with VBA. 

13.2.2 Microsoft Access 2007 

1. Open or create your database. 

2. Edit or create a new form (or report) by clicking Create ►Form Design (or Report Design). 

3. Click View Code in the “Design” ribbon or use the shortcut Alt+F11 to open the Microsoft
®
 

Visual Basic editor. 

4. Click Tools ► References and check TFORMer 6.0 Runtime Type Library to insert a 
reference to TFORMer SDK. 

5. Click OK. 

6. TFORMer SDK may now be used with VBA. 
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13.2.3 Microsoft Word 2003 / Excel 2003 

1. Open or create your document. 

2. Activate the Visual Basic-Editor. This can be done by pressing the keyboard shortcut 
Alt+F11 or by enabling the Visual Basic toolbar and clicking onto the Visual Basic-Editor 
button.  

3. In the Visual Basic editor click Tools ► References and check TFORMer 6.0 Runtime Type 
Library to insert a reference to TFORMer SDK. 

4. Click OK. 

5. TFORMer SDK may now be used with VBA. 

13.2.4 Microsoft Access 2003 

1. Open or create your database. 

2. Create a form or report by selecting Insert ► Form (Report) in the menu. 

3. An empty form (or report) is opened.  

4. Make sure the Design view is activated. This can be done by selecting View ► Design in the 
menu. 

5. Open the Visual Basic-Editor by selecting  View ► Code in the menu or by clicking the View 
Code symbol in the Form Design toolbar. 

6. In the Visual Basic editor click Tools ► References and check TFORMer 6.0 Runtime Type 
Library to insert a reference to TFORMer SDK. 

7. Click OK. 

8. TFORMer SDK may now be used with VBA. 

13.2.5 Other Microsoft Office versions 

The required steps are similar to the steps outlined for Microsoft
®
 Office 2003. 

13.3 More Information 

For more information, please check out the following documents and sample applications: 

 COM Programming Reference  
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ►Documentation ► COM 
Programming Reference 

 Sample Microsoft Excel Spreadsheet using TFORMer SDK 
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ► Examples ► Microsoft Office 
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14 TFORMer in Web Applications 

14.1 TFORMer SDK with Windows based Web-Applications 

14.1.1 Client-side use of TFORMer SDK 

When printing from within a web browser the user usually has to confirm the print job by selecting a 
target printer (this is due to browser implementation details). You can avoid this limitation by using 
the COM component of TFORMer SDK. It enables your web-based application to print to arbitrary 
printers without any user interaction.  

These are the steps to use the COM based API of TFORMer SDK within web pages on client-side: 

1. The TFORMer SDK COM component has to be installed on each client. Take care that only 
Microsoft

®
 Internet Explorer is supported. A CAB file for automatic installation is available 

from TEC-IT. 

2. Use VBScript
®
 or JavaScript

TM
 in a web-page which instantiates a TFORMer class (a sample 

using VBScript is installed by the setup). Check out the following menu entry: 
Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ► Examples ► Programming 

3. Provide the form layouts either locally on the client, on a shared network folder, as BASE64 
strings embedded directly into the HTML page or via http:// on an arbitrary server (see 
14.1.3).  

4. The web page provides data to the TFORMer SDK COM object programmatically. 

5. You web application prints to local printers without any extra user confirmation. 

 

14.1.2 TFORMer SDK on a Windows-based Web-Server 

TFORMer SDK at server-side can be used as part of web applications or web services. Server-side 
use does not bind your clients to specific browsers or operating systems. 

Some .NET based sample applications demonstrate the use of TFORMer SDK with server-based 
web applications. Check out the following menu entry: 

Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ► Examples ► Programming 

14.1.3 Web Based Form Layouts 

TFORMer SDK is able to access form layouts, repositories or data files via http. When using tfprint 
this looks like tfprint -F "http://something.com/OnlineReport_1.tff" … 

14.2 TFORMer SDK on Linux/UNIX based Servers 

The TFORMer SDK can be incorporated easily into server-based applications. Your server-based 
application (e.g. written in PHP, CGI-Perl, Java, C/C++, …) invokes tfprint as external process to 
generate the output data (e.g. a PDF file). 

The TFORMer SDK for Linux/UNIX includes a ready-to-use example showing how tfprint can be 
integrated in a web application. The sample application is written in PHP and is installed in: 

/usr/local/share/TFORMer/SampleCodeCGI 

This sample requires a configured apache web server which supports PHP5. To deploy the applica-
tion, all files in the application directory have to be copied into the root directory of the web server. 
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The file feedback.php contains the application logic to supply user data using XML to tfprint and to 
create a PDF file from the user data and a form layout file. 

14.3 TFORMer SDK on Java Web-Applications 

Through the Java component of TFORMer SDK, it's possible to build J2EE printing applications and 
deploy them into the J2EE Application Server (i. e. Tomcat and JBoss). 

This solution permits to print files on server-side, based on certain user configurations or data. 

It's important to remember that the Application Server must read the TFORMer DLLs or shared 
libraries in order to access to the TFORMer SDK. For details see chapter 11, Java Component. 

Check out the following menu entry to find simple examples of JSP/Servlet using the Java 
component of TFORMer SDK: 

Start Menu ► All Programs ► TEC-IT TFORMer 6.0 ► Examples ► Programming 
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15 FAQ 

15.1 Linux/UNIX 

15.1.1 TFORMer does not work 

If there are any problems with the installation of TFORMer SDK we recommend executing the 
following script: 

$ /usr/local/share/TFORMer/support.sh 

This script is installed by the setup application and lists all relevant information like installed 
operating system, library versions and the TFORMer SDK version. 

Contact the support of TEC-IT (support@tec-it.com) with the output of this script along with a de-
tailed error description.  

15.1.2 TFORMer SDK does not print texts (32 bit TFORMer on 64-bit systems) 

The output generated by the TFORMer SDK only contains images, lines, rectangles or similar ele-
ments. Text elements are not shown. 

Most likely this problem occurs if you are using a 32-bit build of TFORMer on a 64 bit system. 
Please make sure iconv/gconv (character set conversion) is installed correctly. (Re-)Install glibc-
32bit using yast to solve the problem. 

15.1.3 TFORMer SDK does not print Umlauts (e.g. ÄÖÜäöüß) 

If you are using a text file for data import (e.g. with tfprint) and if this file was generated on Win-
dows, TFORMer is not able to print special characters like Ä or Ü.  

To avoid this problem use XML import files (this is the recommended way). Another possibility is to 
convert the text file with iconv to UTF-8 (TFORMer SDK uses UTF-8 internally on Linux/Unix 
platforms): 

$ iconv –f Windows-1252 –t UTF-8 –o output.csv input.csv 

15.1.4 Fonts are looking strange / Errors in the generated layout 

When generating output TFORMer tries to match fonts available on your system with fonts used in 
the form layout.  

Most likely the form layout uses Windows-based fonts (like Arial) which are not available on your 
box. If an exact font matching is not possible the output may look strange. In order to avoid this 
behavior install the required fonts on your Linux/UNIX machine. 

Use the following commands which are part of the fontconfig package to install new fonts: 

 fc-list: list all of the fonts currently available on your box. 

 fc-cache: add additional fonts. 




