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2 Disclaimer 

The actual version of this product (document) is available as is. TEC-IT declines all warranties 
which go beyond applicable rights. The licensee (or reader) bears all risks that might take place 
during the use of the system (the documentation). TEC-IT and its contractual partner cannot be 
penalized for direct and indirect damages or losses (this includes non-restrictive, damages through 
loss of revenues, constriction in the exercise of business, loss of business information or any kind of 
commercial loss), which is caused by use or inability to use the product (documentation), although 
the possibility of such damage was pointed out by TEC-IT.  

 

 
We reserve all rights to this document and the information contained therein. Reproduction, 
use or disclosure to third parties without express authority is strictly forbidden. 
 

 
Für dieses Dokument und den darin dargestellten Gegenstand behalten wir uns alle Rechte 
vor. Vervielfältigung, Bekanntgabe an Dritte oder Verwendung außerhalb des vereinbarten 
Zweckes sind nicht gestattet. 
 

© 1998-2008  
TEC-IT Datenverarbeitung GmbH  
Wagnerstr. 6 

A-4400 Austria  
t.: +43 (0)7252 72720  
f.: +43 (0)7252 72720 77  
http://www.tec-it.com 

http://www.tec-it.com/
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3 Introduction 

3.1 What is TBarCode? 

TBarCode is a set of professional tools for the generation of barcodes. More than 80 different sym-
bologies (linear barcodes, 2D barcodes and stacked barcode variants) can be printed or exported 
as graphics files. All industry formats are supported. The barcodes can be generated in the highest 
possible resolution and quality. 

TBarCode is available in several versions for different operating systems, applications and 

programming environments. The following versions are included in this setup: 

TBarCode OCX A Microsoft
®
 ActiveX

®
 compliant barcode control. It can be used with 

Microsoft
®
 Office applications as well as by software developers. 

TBarCode .NET A .NET barcode library for software developers. It includes barcode 
controls for Windows Forms and ASP.NET 2.0. 

TBarCode Library A DLL for Windows platforms for software developers.  

(A DLL for Windows CE/Windows Mobile is available on request. Please 
contact us with your platform details.) 

3.2 Scope of this Document 

This document concentrates on the use of TBarCode OCX in Microsoft Office applications. 

In contrast to the other two components (TBarCode .NET, TBarCode Library) TBarCode OCX 
may be used without any programming knowledge. This makes it easy to use and you will get 
results in quasi no time. Using the OCX control you can integrate bar codes in text documents, 
spreadsheets and the like. First insert the barcode object in the desired document. Then adjust the 
barcode properties (barcode type, data, etc.) in the provided dialogs. 

The first part of the document explains how to use TBarCode OCX in Office Applications like Word, 
Excel, Access and InfoPath. A few simple examples also demonstrate the possibility of pro-
gramming the control in Visual Basic for Applications. 

The second part of this document describes all available barcode properties, which can be adjusted 
in the property dialogs. All of these parameters are described in detail. 

If you are a software developer and if you are interested in integrating barcode features into your 
own applications please check out the accompanying developer manuals, developer references 
and sample applications (see Appendix A). 

3.3 What is TBarCode OCX? 

TBarCode OCX is a Microsoft
®
 ActiveX

®
 compliant barcode control. Such an ActiveX control is 

sometimes called OLE control or OCX control. In German it is named "Steuerelement". 

You can use TBarCode OCX in: 

Á Microsoft
®
 Office: barcodes are embedded into documents, forms or databases easily. 

Á Development environments: integrate barcodes into your own application(s). 

Á Report-Generators and Reporting Engines: Enhance the output with barcode functionality. 

Á Web Applications: Use barcode technique as part of browser-based applications.  
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Á Most programming and script languages. 

Examples
1
, where you can use TBarCode OCX for barcode generation: 

Á Microsoft Word 

Á Microsoft Excel
®
 

Á Microsoft Access
®
 

Á Microsoft InfoPath
®
 

Á Microsoft SharePoint
®
 

Á Microsoft Visio
®
 

Á Microsoft Visual Basic
®
 

Á Microsoft Visual C++
®
 

Á Microsoft ASP (VBscript
®
) 

Á Microsoft Internet Explorer
®
 

Á Microsoft Visual FoxPro
®
 

Á Microsoft Dynamics Nav
®
 

Á Navision Financials
®
 

Á PHP 4.x, PHP 5.x 

Á Borland C++ Builder
®
 

Á Borland Delphi
®
 

Á Borland Quick Reports
®
 

Á Sybase
®
 Powerbuilder 

Á Crystal Reports
®
 8 

Á ActiveReports (Data Dynamics) 

Á IBM
®
 Object REXX

®
 

Á Alpha Five Database (Xbasic) 

Á ASNA Visual RPG
®
 

Á and a lot of more applicationsé 

3.4 Restrictions of the Demo Version 

In the demo version the barcodes will be drawn with a demo-hint. That means that the word ñDemoò 
or the phrase ñwww.tec-it.comò is drawn partially over the barcode. The demo-hint does not influ-
ence the readability of the barcode in a negative way. 

Ʒ In special cases (e.g. very small or high-resolution barcodes) you may want to test the pro-
duct without restrictions. To obtain a temporary license key contact sales@tec-it.com. 

Ʒ For enabling the full-featured version (without the demo hints) you can obtain a license key 
from TEC-IT (http://www.tec-it.com/order/). 

Ʒ For more information on licensing TBarCode, please refer to chapter 12. 

3.5 Important Security Notice 

Ʒ Version 8.0 and newer versions include a fix which was implemented in response to a 
security leak (a malicious web-site in conjunction with Internet Explorer and an installed 
TBarCode ActiveX). Up to now no real threat is known, but it is strongly recommended to 

update all TBarCode installations as soon as possible. 

                                                      
1
 For applications not supporting ActiveX technology you may use other TEC-IT Barcode Tools (e.g. Barcode Studio). 

http://www.tec-it.com/
mailto:sales@tec-it.com
http://www.tec-it.com/order/
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4 Installation 

4.1 Requirements 

The following operating systems are supported: 

Á Microsoft Windows 98  

Á Microsoft Windows 98 Second Edition 

Á Microsoft Windows ME 

Á Microsoft Windows NT 4 

Á Microsoft Windows 2000 

Á Microsoft Windows XP 

Á Microsoft Windows Server 2003 

Á Microsoft Windows Vista  

TBarCode OCX was tested with the following Microsoft Office versions (in particular with Microsoft 

Word, Excel, Access, Visio
2
 and InfoPath

3
): 

Á Microsoft Office 97
4
   

Á Microsoft Office 2000  

Á Microsoft Office 2002/XP  

Á Microsoft Office 2003  

Á Microsoft Office 2007  

4.2 Download and Setup 

Download TBarCode from http://www.tec-it.com/Download Ʒ TBarCode and execute the setup 
application. Depending on your selection one or more of the following components are installed ï 
along with documentations and sample applications:  

Á TBarCode OCX 
A barcode ActiveX control for Microsoft Office users and for software developers. User 
manual and API reference are included in the setup. 

Á TBarCode Library 
For software developers. Developer manual and API reference are included in the setup. 

Á TBarCode .NET 
For .NET developers. Developer manual and API reference are included in the setup. 

 

Ʒ Administrative rights are required to install TBarCode.  

Ʒ TBarCode OCX is an ActiveX control. ActiveX controls must be registered within the Micro-
soft Windows operating system before they can be used. This registration is executed auto-
matically by the setup application. On demand you can register the OCX file manually with 
the command line tool ñregsvr32.exeò. 

 

                                                      
2
 For Office 2003 and higher 

3
 For Office 2003 and higher 

4
 Excel ô97 is only supported by TBarCode4 

http://en.wikipedia.org/wiki/Microsoft_Office_2007
http://www.tec-it.com/Download
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5 Insert Barcode  

5.1 General (Microsoft Office) 

This and the following chapters will explain how to use TBarCode in Microsoft Office applications. 
For the following three products the usage of the TBarCode control is basically the same: 

Á Microsoft Word 2003 (and earlier versions) 

Á Microsoft Excel 2003 (and earlier versions) 

Á Microsoft Access 2003 (and earlier versions) 

In Office 2007 inserting the TBarCode control has slightly changed. How to do this is explained in 

sections 5.5 and 5.6: 

Á Insert Barcode in Microsoft Word 2007 

Á Insert Barcode in Microsoft Excel 2007 

Finally, the usage of TBarCode in Microsoft InfoPath is explained in chapter 10. 

5.2 Insert Barcode using the Menu 

 
Figure 1: Insert Barcode using the Menu (Microsoft Word) 

Application How to insert 

Word Á Select Insert Ʒ Objecté from the menu (¬). 

Á Select TBarCode9 from the list of object types ­ and confirm with OK. 

Á A new barcode object will be inserted (®). 
Excel 

Access Á Open your report (or form) in the design mode (see 6.2). 

Á Select Insert Ʒ ActiveX Controlé from the menu. 

Á Select TBarCode9 from the list of object types and confirm with OK. 

¬ 

® 

­ 
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Á A new barcode object will be inserted. 

InfoPath Please refer to section 10.4. 

5.3 Insert Barcode using the Control Toolbox 

 
Figure 2: Insert Barcode using the Control Toolbox (Microsoft Word) 

Ʒ Please note: In Word and Excel the toolbar is named ñControl Toolboxò, in Access just ñTool-
boxò. 

 

Application How to insert 

Word Á If the Control Toolbox ¬ is not visible, please open it as follows: 

­ right-click on one of the visible toolbars and select Control Toolbox or 
­ select View Ʒ Toolbars Ʒ Control Toolbox from the menu. 

Á Click on the More Controls icon­. ï A list with available controls will 
appear (see ®). 

Á Select the entry TBarCode9. 

Á Now move the mouse cursor to the desired position and click the left 
mouse button. The TBarCode control  ̄will be inserted. 

Excel 

Access 

InfoPath Please refer to section 10.4. 

5.4 Insert Barcode per Code 

Using VBA (Visual Basic for Applications) you can insert the barcode per code. For more informa-
tion, please refer to section 8.3. 

5.5 Insert Barcode in Word 2007 

The easiest way to insert a barcode in Microsoft Word is to use the New Barcode function in the 
TBarCode Toolbar which is located in the Add-Ins tab. It will insert a new barcode at the current 
cursor position. If a text is selected when pressing the button this text is automatically used as bar-
code data. 

For a detailed description on the TBarCode toolbar and its functions, please refer to chapter 9. 

¬ 
­ 

® 

¯ 
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If you have not installed the TBarCode Office Add-In you can also insert a barcode as follows: 

Á Click the Office button on the top left of the Word window and then select Word Options. 

 

Á Enable the Developer Tab in the Ribbon: 

 

Á Then go to the Developer tab and click Legacy Tools Ʒ More Controls. Select TBarCode9 
from the list of ActiveX Controls and confirm with OK. The barcode will be inserted at the 
current cursor position. 
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5.6 Insert Barcode in Excel 2007 

Á Enable the Developer Tab in the Ribbon (Excel Options) 

 

 
Figure 3: Excel 2007: Excel Options - Show Developer tab 

Á Go to the Developer tab and select Insert Ʒ More Controls 

 

 
Figure 4: Excel 2007: More Controls 

 
Figure 5: Excel 2007: Select TBarCode9 

 

Á Select TBarCode9 from the list of object types and confirm with OK. 

Á Now move the mouse cursor to the desired position and draw a rectangle to the position 
where the bar code should be. A TBarCode control will be inserted. 

 

Ʒ Please note: In Word 2007 and Excel 2007 the òControl Toolboxò can be found in the 

Developer Tab, in Access 2007 inside the Design Tab.  
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6 Adjust Barcode Parameters  

6.1 General 

TBarCode offers the possibility to change all barcode related settings (barcode type, barcode data, 
check digit method, barcode appearance, etc.) to your needs. There are three different methods for 
changing barcode parameters. These methods are explained in section 6.3. 

Ʒ Please keep in mind:  
In order to select, move, resize, edit and program the TBarCode control you have to be in 
Design Mode. When leaving the design mode, the control is locked and can not be edited. 

6.2 Activate the Design Mode 

Application How to activate the Design Mode 

Word See section 6.2.1. 

Excel 

Access See section 6.2.2. 

InfoPath See section 10.2. 

6.2.1 Microsoft Word or Excel 

 

Switch to Design Mode by clicking on the triangle 
symbol ¬ in the Control Toolbox. 

 

If the control toolbox is not visible, please open it 
as follows: 

Á Right-click on one of the visible toolbars 
and select Control Toolbox or 

Á Select View Ʒ Toolbars Ʒ Control 
Toolbox from the menu. 

 

6.2.2 Microsoft Access 

 

You can activate the Design Mode when opening 
the form (or report): 

Á Select the desired form (or report) and click 
on the Design button ¬ or 

Á Right-click on the form/report name and 
select Design View (­) from the pop-up 
menu. 

 

¬ 

¬ 

­ 
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6.3  Barcode Parameters 

The barcode parameters can be adjusted using either the Property Pages, the Property List or VBA 
Code.  
Except for some special settings (which are available in the property list or via code only) TEC-IT 
recommends the use of the property pages. The property pages are designed for easy adjustment 
of the TBarCode properties. 

6.3.1 Property Pages 

 
Figure 6: Property Pages (Microsoft Word) 

Application How to open the Property Pages 

Word Á Make sure that you are in Design Mode (see section 6.2). 

Á Right-click on the TBarCode object ¬. 

Á Select TBarCode9 Object Ʒ Properties from the pop-up menu (­). 

Á The property pages ® will appear. 

Excel 

Access 

InfoPath Á Make sure that you are in Design Mode. 

Á Right-click on the TBarCode object and select TBarCode9 Propertiesé 

 

Ʒ For detailed information about the property pages and about the available settings, please 
refer to chapter 11. 

­ ¬ 

® 


