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2 Disclaimer 

The actual version of this product (document) is available as is. TEC-IT declines all warranties 
which goes beyond applicable rights. The licensee (or reader) bears all risks that might take place 
during the use of the system (the documentation). TEC-IT and its contractual partner cannot be 
penalized for direct and indirect damages or losses (this includes non-restrictive, damages through 
loss of revenues, constriction in the exercise of business, loss of business information or any kind of 
commercial loss), which is caused by use or inability to use the product (documentation), although 
the possibility of such damage was pointed out by TEC-IT.  

 

 
We reserve all rights to this document and the information contained therein. Reproduction, 
use or disclosure to third parties without express authority is strictly forbidden. 
 

 
Für dieses Dokument und den darin dargestellten Gegenstand behalten wir uns alle Rechte 
vor. Vervielfältigung, Bekanntgabe an Dritte oder Verwendung außerhalb des vereinbarten 
Zweckes sind nicht gestattet. 
 

© 1998-2007  
TEC-IT Datenverarbeitung GmbH  
Wagnerstr. 6 

A-4400 Austria  
t.: +43 (0)7252 72720  
f.: +43 (0)7252 72720 77  
http://www.tec-it.com 
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3 Introduction 

3.1 What is TBarCode? 

TBarCode is a set of professional tools for the generation of barcodes. More than 70 different 
symbologies (linear as well as 2D or stacked barcode variants) can be printed or exported as 
graphics file. All industry formats, in the highest possible resolution and quality, are generated. 

TBarCode is available in several versions for different operating systems, applications and 

programming environments. The following versions are included in this setup: 

TBarCode OCX A Microsoft
®
 ActiveX

®
 compliant barcode control. It can be used with 

Microsoft
®
 Office applications as well as by software developers. 

TBarCode .NET A .NET barcode library for software developers. It includes barcode 
controls for Windows Forms and ASP.NET 2.0. 

TBarCode Library A DLL for Windows platforms for software developers.  

(A DLL for Windows CE/Windows Mobile is available on request. Please 
contact us with your platform details.) 

3.2 What is TBarCode OCX? 

TBarCode OCX is a Microsoft
®
 ActiveX

®
 compliant barcode control. Such an ActiveX control is 

sometimes called OLE control or OCX control. In German it is named "Steuerelement". 

You can use TBarCode OCX in: 

 Microsoft
®
 Office: barcodes are embedded into documents, forms or databases easily. 

 Development environments: integrate barcodes into your own application(s).  

 Report-Generators and Reporting Engines: Enhance the output with barcode functionality. 

 Web Applications: Use barcode technique as part of browser-based applications.  

 Most programming and script languages. 

Examples
1
, where you can use TBarCode OCX for barcode generation: 

 Microsoft Word 

 Microsoft Excel
®
 

 Microsoft Access
®
 

 Microsoft InfoPath
®
 

 Microsoft SharePoint
®
 

 Microsoft Visio
®
 

 Microsoft Visual Basic
®
 

 Microsoft Visual C++
®
 

 Microsoft ASP (VBscript
®
) 

 Microsoft Internet Explorer
®
 

 Microsoft Visual FoxPro
®
 

 Microsoft Dynamics Nav
®
 

 Navision Financials
®
 

 PHP 4.x, PHP 5.x 

 Borland C++ Builder
®
 

 Borland Delphi
®
 

 Borland Quick Reports
®
 

 Sybase
®
 Powerbuilder 

 Crystal Reports
®
 8 

 ActiveReports (Data Dynamics) 

 IBM
®
 Object REXX

®
 

 Alpha Five Database (Xbasic) 

 ASNA Visual RPG
®
 

 and a lot of more applications… 

3.3 Scope of this Document 

This document concentrates on the use of TBarCode OCX in Microsoft Office applications.  

If you are a software developer and you are interested in integrating barcode features into your 
own applications, please check out the accompanying developer manuals, developer references 
and sample applications (Appendix A). 

                                                      
1
 For applications not supporting ActiveX technology you may use other TEC-IT Barcode Tools (e.g. Barcode Studio). 
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3.4 Restrictions of the Demo Version 

In the demo version the barcodes will be drawn with a demo-hint. That means that the word “Demo” 
or the phrase “www.tec-it.com” is drawn partially over the barcode. The demo-hint does not influ-
ence the readability of the barcode in a negative way. 

► In special cases (e.g. very small or high-resolution barcodes) you may want to test the pro-
duct without restrictions. To obtain a temporary license key contact sales@tec-it.com. 

► For enabling the full-featured version (without the demo hints) you can obtain a license key 
from TEC-IT (http://www.tec-it.com/order/). 

► For more information on licensing TBarCode, please refer to chapter 12. 

3.5 Important Security Notice 

► Version 8.0 includes a fix which was implemented in response to a security leak (a malicious 
web-site in conjunction with Internet Explorer and an installed TBarCode ActiveX). Up to 
now no real threat is known, but it is strongly recommended to update all TBarCode 
installations as soon as possible. 
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4 Installation 

4.1 Requirements 

The following operating systems are supported: 

 Microsoft Windows 98  

 Microsoft Windows 98 Second Edition 

 Microsoft Windows ME 

 Microsoft Windows NT 4 

 Microsoft Windows 2000 

 Microsoft Windows XP 

 Microsoft Windows Server 2003 

 Microsoft Windows Vista  

TBarCode OCX was tested with the following Microsoft Office versions (in particular with Microsoft 

Word, Excel, Access, Visio
2
 and InfoPath

3
): 

 Microsoft Office 97
4
   

 Microsoft Office 2000  

 Microsoft Office 2002/XP  

 Microsoft Office 2003  

 Microsoft Office 2007  

4.2 Download and Setup 

Download TBarCode from http://www.tec-it.com/Download ► Software ► Barcode Tools for Micro-
soft Windows and execute the setup application. Depending on your selection one or more of the 

following components are installed – along with documentations and sample applications:  

 TBarCode OCX 
A barcode ActiveX control for Microsoft Office users and for software developers. User 
manual and API reference are included in the setup. 

 TBarCode Library 
For software developers. Developer manual and API reference are included in the setup. 

 TBarCode .NET 
For .NET developers. Developer manual and API reference are included in the setup. 

 

► Administrative rights are required to install TBarCode.  

► TBarCode OCX is an ActiveX control. ActiveX controls must be registered within the 
Microsoft Windows operating system before they can be used. This registration is executed 
automatically by the setup application. On demand you can register the OCX file manually 
with the command line tool “regsvr32.exe”. 

 

                                                      
2
 For Office 2003 and higher 

3
 For Office 2003 and higher 

4
 Excel ’97 is only supported by TBarCode4 
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5 Insert Barcode  

5.1 General 

This and the following chapters will explain how to use TBarCode in Microsoft Office applications. 
For the following three products the usage of the TBarCode control is basically the same: 

 Microsoft Word 

 Microsoft Excel 

 Microsoft Access 

Using TBarCode in Microsoft InfoPath is explained in detail in chapter 10. 

5.2 Insert Barcode using the Menu 

 
Figure 1: Insert Barcode using the Menu (Microsoft Word) 

Application How to insert 

Word  Select Insert ► Object… from the menu (). 

 Select TBarCode8 from the list of object types  and confirm with OK. 

 A new barcode object will be inserted (). 
Excel 

Access  Open your report (or form) in the design mode (see 6.2). 

 Select Insert ► ActiveX Control… from the menu. 

 Select TBarCode8 from the list of object types and confirm with OK. 

 A new barcode object will be inserted. 

InfoPath Please refer to section 10.4. 






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5.3 Insert Barcode using the Control Toolbox 

 
Figure 2: Insert Barcode using the Control Toolbox (Microsoft Word) 

► Please note: In Word and Excel the toolbar is named ”Control Toolbox”, in Access just “Tool-
box”. 

 

Application How to insert 

Word  If the Control Toolbox  is not visible, please open it as follows: 

­ right-click on one of the visible toolbars and select Control Toolbox or 
­ select View ► Toolbars ► Control Toolbox from the menu. 

 Click on the More Controls icon. – A list with available controls will 
appear (see ). 

 Select the entry TBarCode8. 

 Now move the mouse cursor to the desired position and click the left 
mouse button. The TBarCode control  will be inserted. 

Excel 

Access 

InfoPath Please refer to section 10.4. 

5.4 Insert Barcode per Code 

Using VBA (Visual Basic for Applications) you can insert the barcode per code. For more infor-
mation, please refer to section 8.3. 







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6 Adjust Barcode Parameters  

6.1 General 

TBarCode offers the possibility to change all barcode related settings (barcode type, barcode data, 
check digit method, barcode appearance, etc.) to your needs. There are three different methods for 
changing barcode parameters. These methods are explained in section 6.3. 

► Please keep in mind:  
In order to select, move, resize, edit and program the TBarCode control you have to be in 
Design Mode. When leaving the design mode, the control is locked and can not be edited. 

6.2 Activate the Design Mode 

Application How to activate the Design Mode 

Word See section 6.2.1. 

Excel 

Access See section 6.2.2. 

InfoPath See section 10.2. 

6.2.1 Microsoft Word or Excel 

 

Switch to Design Mode by clicking on the triangle 
symbol  in the Control Toolbox. 

 

If the control toolbox is not visible, please open it 
as follows: 

 Right-click on one of the visible toolbars 
and select Control Toolbox or 

 Select View ► Toolbars ► Control 
Toolbox from the menu. 

 

6.2.2 Microsoft Access 

 

You can activate the Design Mode when opening 
the form (or report): 

 Select the desired form (or report) and click 
on the Design button  or 

 Right-click on the form/report name and 
select Design View () from the pop-up 
menu. 

 






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6.3  Barcode Parameters 

The barcode parameters can be adjusted using either the Property Pages, the Property List or VBA 
Code.  
Except for some special settings (which are available in the property list or via code only) TEC-IT 
recommends the use of the property pages. The property pages are designed for easy adjustment 
of the TBarCode properties. 

6.3.1 Property Pages 

 
Figure 3: Property Pages (Microsoft Word) 

Application How to open the Property Pages 

Word  Make sure that you are in Design Mode (see section 6.2). 

 Right-click on the TBarCode object . 

 Select TBarCode8 Object ► Properties from the pop-up menu (). 

 The property pages  will appear. 

Excel 

Access 

InfoPath  Make sure that you are in Design Mode. 

 Right-click on the TBarCode object and select TBarCode8 Properties… 

 

► For detailed information about the property pages and about the available settings, please 
refer to chapter 11. 






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6.3.2 Property List 

 
Figure 4: Property List (Microsoft Word) 

Application How to open the Property List 

Word  Make sure that you are in Design Mode (see section 6.2). 

 Right-click on the TBarCode object  and select Properties () from 
the pop-up menu. 
As an alternative you can also select the barcode and click on the 
Properties icon  in the Control Toolbox. 

 The property pages  will appear. 

Excel 

Access 

InfoPath No property list available. 

 

► Some properties – in particular data binding (“Linked Cell” in Excel or “Control Source” in 
Access) – are available in the property list only. For more information on data binding, 
please refer to section 7.3. 

6.3.3 Adjust Parameters per Code 

Using VBA (Visual Basic for Applications) you can adjust the barcode parameters per code. For 
more information, please refer to section 8.4. 








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7 Set Barcode Data (Data Binding) 

7.1 General 

The barcode data can be provided in three ways: 

 Manually 

 Via Data Binding 

 Via VBA (Visual Basic for Applications) 

7.2 Specify Data Manually 

You can specify the barcode data in the property pages or the property list: 

7.2.1 Property Pages 

 

 Open the property pages (see section 
6.3.1). 

 Select the “Barcode” tab. 

 Enter the desired text in . 

7.2.2 Property List 

 

 Open the property list (see 
section 6.3.2). 

 Select the Text property. 

 Enter the desired text in . 

7.3 Data Binding 

Some Microsoft Office applications provide the option to bind the content of a specified data field to 
the TBarCode control (“data binding”). This means that the barcode control will use the content of 
the data field as barcode data. Whenever you change the content of the data field the barcode 
symbol will be updated as well. 

Application Data Binding 

Word Not available. 

Excel See section 7.3.1. 

Access See section 7.3.2. 

InfoPath See sections 10.3 to 10.5. 




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7.3.1 Microsoft Excel 

Data binding can be enabled via the property LinkedCell: 

 Make sure that you are in Design Mode (see section 6.2). 

 Select the TBarCode object . 

 Then click on the Properties icon  in the Control Toolbox. 
(If you have inserted the barcode using the Control Toolbox (see section 5.3) you can alter-
natively right-click on the TBarCode object  and select Properties  from the pop-up menu.) 

 The property list  will appear. 

 Select the property LinkedCell and as value enter the name of the cell that you want to bind 
to the TBarCode control (see ). In this sample B7 is used. 

 

 
Figure 5: Data Binding in Microsoft Excel 

7.3.2 Microsoft Access 

The barcode control can be used in reports and forms. Most commonly the barcode is bound to a 
table column. If this is done, the barcode changes according to the data record which is currently 
being displayed. 

In order to bind the barcode to a data source, please execute the following steps: 

 Right-click on the TBarCode object . 

 Select Properties from the pop-up menu . 

 Select the Data tab . 

 For the property Control Source select the data field (or the query) that serves as source for 
the barcode content (see ).  
This step is only possible if you have previously defined a data-source for the report/form. 
You can do this by opening the properties dialog for the entire report. 

 












