
 
 
 

Barcode Studio 
Barcode Designer 

Vers ion 8.0 

 
 
 
 

User Manual 
 
 
 
 
 
 
 
 
 

11 June 2008 

 
TEC-IT Datenverarbeitung Gm bH 

Wagnerstrasse 6  
A-4400 Steyr ,  Austr ia  

 
t  ++43 (0)7252 72720 

f  ++43 (0)7252 72720 77  
of f ice@tec- i t .com 

www.tec- i t .com 
 



 
 
 

Page 2 of 47 

 

Barcode Studio User Manual  

1 Content 

1 Content 2 
1.1 Table of Figures 3 
1.2 List of Tables 4 

2 Disclaimer 5 

3 Introduction 6 
3.1 About 6 
3.2 Supported Operating Systems 6 
3.3 Restrictions of the Demo Version 6 

4 Installation 7 
4.1 Install Barcode Studio on Microsoft

®
 Windows 7 

4.2 Install Barcode Studio on Mac OS X
®
 (10.4 or higher) 7 

5 Quick-Start 8 
5.1 Introduction 8 
5.2 How to Create an EAN13 Bar Code 8 

5.2.1 Select Bar Code Type (Symbology) 9 
5.2.2 Enter Bar Code Data 9 
5.2.3 Select Output Resolution 10 
5.2.4 Specify Bar Code Dimensions 10 
5.2.5 Fine-tune the Module Width 11 
5.2.6 Set Font Style and Size 11 

6 Using Bar Codes in Applications  (Exporting Bar Codes) 12 
6.1 General 12 
6.2 Resolution and Readability 12 
6.3 Export to File 13 
6.4 Copy Barcode to Clipboard 13 
6.5 Copy Metafile to Clipboard 13 
6.6 Export a Series of Bar Codes 13 

7 Barcode Studio User Interface 14 
7.1 Main Window and Menu 14 
7.2 Menu 15 

7.2.1 File 15 
7.2.2 Export 15 
7.2.3 Tools 15 
7.2.4 Help 15 

7.3 Toolbar 16 
7.4 Quality Watch – Status Section 16 

7.4.1 Deviation 16 
7.4.2 Quality 17 
7.4.3 Character Count 17 
7.4.4 Resolution 17 
7.4.5 Hint Box 17 

7.5 Symbology 17 
7.6 The Bar Code View 17 
7.7 Page General 18 

7.7.1 Data 18 
7.7.2 Appearance 19 
7.7.3 Text Placement 22 

7.8 Page Settings 22 
7.8.1 Drawing 22 
7.8.2 Advanced Data Manipulation 24 

7.9 2D Settings 25 
7.9.1 PDF417 / Micro PDF417 25 
7.9.2 MaxiCode 29 
7.9.3 Data Matrix 30 
7.9.4 QR-Code 31 
7.9.5 Aztec Code 33 
7.9.6 Codablock-F 34 
7.9.7 Composite Symbology 35 

8 Sequences 37 
8.1 General 37 
8.2 Sequence Export 37 

8.2.1 Create Sequence 37 
8.2.2 Import Sequence 38 
8.2.3 Export Bar Codes 39 



 
 
 

Page 3 of 47 

 

Barcode Studio User Manual  

9 Options 40 
9.1 Output 40 

9.1.1 Draw Mode 40 
9.2 Font Substitution for EPS Export 40 

9.2.1 Font Substitution 40 
9.2.2 Surrogate Font 40 

10 FAQ 41 
10.1 How can I encode the FNC1 character in EAN128? 41 
10.2 How can I encode the FNC1 character in EAN Data Matrix? 41 
10.3 Escape-Sequences are not encoded (and the scanner signals an error) 41 
10.4 After saving the bar code to an image file, my bar code scanner cannot read the bar code! 41 

11 Licensing 42 
11.1 License Types 42 
11.2 Entering your License Data 42 

11.2.1 License Dialog 42 

12 Contact and Support Information 43 

Appendix A : Bar Codes 44 
A.1 Supported Bar Codes 44 

A.1.1 MaxiCode 44 
A.2 Check Digits 44 
A.3 Print Ratio 44 
A.4 Format 44 
A.5 Escape Sequences 44 

Appendix B : Error Messages 45 

Appendix C : Image Types 46 

Appendix D : Command Line Parameters 47 
D.1 Syntax 47 
D.2 Examples 47 

 

1.1 Table of Figures 

Figure 1: Quick-Start – Barcode Studio Main Window 8 
Figure 2: User Interface 14 
Figure 3: Toolbar 16 
Figure 4: Quality Watch 16 
Figure 5: Bar Code View 17 
Figure 6: Data Section 18 
Figure 7: Input Data (Dialog) 18 
Figure 8: Add Control Character 18 
Figure 9: Appearance Section 19 
Figure 10: Text Placement Section 22 
Figure 11: Drawing Section 22 
Figure 12: Colors Dialog 24 
Figure 13: Advanced Data Manipulation Section 24 
Figure 14: PDF417 / Micro PDF417 Properties 25 
Figure 15: Macro PDF417 Optional Settings 28 
Figure 16: MaxiCode Properties 29 
Figure 17: Data Matrix (ECC200) Properties 30 
Figure 18: QR-Code Properties 31 
Figure 19: Aztec Code Properties 33 
Figure 20: Codablock-F Properties 34 
Figure 21: Composite Symbology Settings 35 
Figure 22: Sequence Export 37 
Figure 23: Export Bar Codes from Sequence 39 
Figure 24: Options Dialog 40 

 



 
 
 

Page 4 of 47 

 

Barcode Studio User Manual  

1.2 List of Tables 

Table 1: EAN13 Dimensions (not complete) 10 
Table 2: Bar code Qualities 16 
Table 3: Units 20 
Table 4: Resolution Settings 21 
Table 5: Micro PDF417 - Modes 27 
Table 6: MaxiCode - Modes 29 
Table 7: Data Matrix - Modes 30 
Table 8: QR Code - Modes 31 
Table 9: QR Code – Error Correction Levels 32 
Table 10: QR Code – Mask Patterns 32 
Table 11: QR Code – Compaction 32 
Table 12: Aztec Code – Modes 33 
Table 13: Codablock-F – Modes 34 
Table 14: Format - Characters 38 
Table 15: Format - Examples 38 
Table 16: Sequence – File Name 39 
Table 17: Draw Modes 40 
Table 18: Font Substitution 40 
Table 19: Error Descriptions 45 
Table 20: Image Data Formats 46 
 



 
 
 

Page 5 of 47 

 

Barcode Studio User Manual  

2 Disclaimer 

The actual version of this product (document) is available as is. TEC-IT declines all warranties 
which go beyond applicable rights. The licensee (or reader) bears all risks that might take place 
during the use of the system (the documentation). TEC-IT and its contractual partners cannot be 
penalized for direct and indirect damages or losses (this includes non-restrictive, damages through 
loss of revenues, constriction in the exercise of business, loss of business information or any kind of 
commercial loss), which is caused by use or inability to use the product (documentation), although 
the possibility of such damage was pointed out by TEC-IT.  

 

 
We reserve all rights to this document and the information contained therein. Reproduction, 
use or disclosure to third parties without express authority is strictly forbidden. 
 

 
Für dieses Dokument und den darin dargestellten Gegenstand behalten wir uns alle Rechte 
vor. Vervielfältigung, Bekanntgabe an Dritte oder Verwendung außerhalb des vereinbarten 
Zweckes sind nicht gestattet. 
 

© 1998-2008  
TEC-IT Datenverarbeitung GmbH  
Wagnerstr. 6 

A-4400 Austria  
t.: +43 (0)7252 72720  
f.: +43 (0)7252 72720 77  
http://www.tec-it.com 
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3 Introduction 

3.1 About 

TEC-IT Barcode Studio is a tool for generating and printing bar codes. All common linear, 2D and 

composite bar code symbologies are supported. 

You can adapt all bar code parameters to your needs, export the bar code to an image file (e.g. for 
using it in your artwork), copy the bar code to the clipboard or print it. 

If you have any questions, please contact our support: support@tec-it.com. 

TEC-IT Datenverarbeitung GmbH 
Wagnerstrasse 6 
AT-4400 Steyr 
AUSTRIA / EUROPE 

3.2 Supported Operating Systems 

 Mac OS (10.4 or higher) for Intel 

 Mac OS (10.4 or higher) for PowerPC 

 Windows Vista 

 Windows XP 

 Windows 2000 

 Windows NT 4.x or higher 

 Windows Server 2003 

 Windows 98 (image dimensions are restricted to 1200 pixels width / height) 

 Windows ME (image dimensions are restricted to 1200 pixels width / height) 

 Linux/UNIX (on request) 

3.3 Restrictions of the Demo Version 

► A demo marker across the bar code indicates that the demo version is active. The 
correctness of the bar code is not affected. 

► To obtain a license key for the full version (without the demo marker) please order Barcode 
Studio online at http://www.tec-it.com/order/default.aspx. 
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4 Installation 

4.1 Install Barcode Studio on Microsoft® Windows 

On Microsoft
®
 Windows operating systems (XP, Vista, …), Barcode Studio is installed with the 

Windows Installer.  

The following steps need to be performed (you need to have administrator privileges). 

1. Open the installer by double-clicking it. 

2. Follow the instructions of the installation wizard. 

By default, Barcode Studio is installed in the following directory: 

C:\Program Files\TEC-IT\BCStudio8  

4.2 Install Barcode Studio on Mac OS X® (10.4 or higher) 

For Mac operating systems (Mac OS X 10.4 or higher), Barcode Studio is provided as a zip-file. 

The following steps need to be performed (you need to have administrator privileges). 

1. Extract the zip-file to an arbitrary directory. 
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5 Quick-Start 

5.1 Introduction 

This chapter will guide you through the most important functions of Barcode Studio by showing 
you how to create an EAN13 bar code. For more detailed explanation of the user interface and the 
available functions and settings, please refer to the chapters 6 and 7. 

5.2 How to Create an EAN13 Bar Code 

 
Figure 1: Quick-Start – Barcode Studio Main Window 

In order to create an EAN13 bar code, please perform the following steps: 

Select the bar code type (symbology) – see section 5.2.1. 

Enter the bar code data - see section 5.2.2. 

Select the output resolution - see section 5.2.3. 

 Specify the bar code dimensions - see section 5.2.4. 

 Fine-tune the module width - see section 5.2.5. 

 Set font style and size - see section 5.2.6. 

 Export or print the bar code. 















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5.2.1 Select Bar Code Type (Symbology) 

 
 

Select the bar code type (symbology) in . Choose 
“EAN13” from the list of symbologies. 

Hint: If you press the E key, the first entry starting 
with an “E” will be selected in the list. 

 

5.2.2 Enter Bar Code Data 

A valid EAN13 bar code needs exactly 12 digits (or 13 digits including the check digit). Because 
current data (“123456”) consists only of 6 digits, Barcode Studio informs you with following error 

message: 

Error: Wrong number of input characters (12 chars needed)! 

 

 

 

Enter the data to be encoded in . You can also 
edit the bar code content in the Bar Code Data 
dialog or import it from a file (see 7.7.1.1). 

  

 

The bar code view is updated after every change. If 
you enter exactly twelve (or thirteen) characters, 
the bar code will be drawn in the bar code view in 
the top left corner. 

If the input data is invalid (e.g. wrong characters or a wrong number of characters) an error 
message will be displayed instead of the bar code. For a list of the most common error messages, 
please refer to Appendix B. 

► The 13
th
 digit in the resulting EAN13 bar code (in this case the digit “3”) is the check digit. It 

will be calculated automatically. 

► If you enter 13 (instead of 12) characters you need to provide the correct check digit by 
yourself. This is not recommended (unless you supply the correct value). A wrong check 
digit may make the bar code unreadable! 




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5.2.3 Select Output Resolution 

► Barcode Studio uses the selected resolution for computing the barcode images. Thus it is 
essential to adjust a resolution which leads to readable bar codes (see also section 5.2.5).   

► Usually higher resolutions lead to better bar code quality. Please notice that it is very 
important that the selected resolution accords to the resolution of the output device (printer, 
image or of image processing / layout software). 

 

 

The output resolution can be adjusted in .  

 

In this example the output resolution is changed to “300 
dpi”. If you are planning to print the bar code on a laser 
printer you would most probably select a higher resolution 
(600 or 1200 dpi). 

If you want to export the bar code as image for your web 
page you could also choose “Screen Resolution” or “72 dpi 
(BMP)”.  

 

► If you use bar code images in pre-press applications, take care to avoid any scaling or 
resizing of the generated bar code image. This may lead to inaccuracies and distortions 
rendering the bar code unusable. Generate the bar code image in exactly the resolution and 
size as required! 

5.2.4 Specify Bar Code Dimensions 

The bar code dimensions can be modified by changing width, height, and module width. 

Most label or bar code specifications require specific bar code dimensions. Following values are 
usual for EAN13: 

Magnification 
factor 

Module width [mm] Width [mm] Height [mm] 

0.80 0.264 (SC0) 29.83 20.73 

1.00 0.330 (SC2) 37.29 25.91 

1.50 0.495 (SC6) 55.94 38.87 

2.00 0.660 (SC9) 74.58 51.82 

Table 1: EAN13 Dimensions (not complete) 

 
 

Here we use the magnification factor 1.00. 

 

Enter the width and the height in . The appropriate module width 
will be calculated automatically. 

 

 

The bar code should now look like this. 




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5.2.5 Fine-tune the Module Width 

Yet the quality of the bar code is not perfect (see the Quality Watch at the top right corner of the 
Barcode Studio‟s application window): 

 

To optimize the bar code quality we recommend you to fine-tune the module width. You have the 
following options: 

 Select the option “Optimal Size” (see Figure 1, ) 

 Choose “Pixel” in field “Unit” and enter a whole-numbered value in the field “Module Width”. 

 Increase the output resolution 

The first two options both lead to a “perfect” bar code quality. 

5.2.6 Set Font Style and Size 

The font properties can be set via the “Select Font” dialog. You can open this dialog by clicking the 

 button in the “Text Placement” section (see Figure 1 ). 

This example uses a 10 pt Courier New font: 
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6 Using Bar Codes in Applications  
(Exporting Bar Codes) 

This chapter is a general instruction for using bar codes generated with Barcode Studio in other 
applications. A detailed explanation of the user interface and available bar code settings can be 
found in the next chapter. 

6.1 General 

You can export the bar codes created in Barcode Studio in the following ways: 

 Copy the bar code to the clipboard (as image) and paste it into your application. 

 Copy the bar code to the clipboard (as metafile) and paste it into your application. 
(available under Microsoft Windows only) 

 Export the bar code to an image file. 

 Export a series of bar code images (batch job). 

Before the export of a bar code you have to adjust the required bar code settings. The size of the 
resulting bar code image can be controlled by changing the dimensions (width, height, and module 
width) and the output resolution (DPI) – see also section 7.7.2 . These settings apply to all kinds of 
export operations.  

6.2 Resolution and Readability 

► Do not resize exported bar code images with image manipulation software (like 
Photoshop

®
)! The quality and the readability might suffer! 

► Whenever possible, let Barcode Studio create the bar code in the required size and 

resolution to avoid resizing later on. 

6.2.1.1 Bar Code Quality 

When exporting the bar code to a bitmap image (BMP, GIF, JPG, PNG, and TIF), it must be 
converted from its internal resolution (high) to a graphical pixel resolution (low). During this process 
(rasterizing) the module width can vary due to rounding errors. 

When exporting a bar code to a vector based image format (EPS, E4C, and E1C) or as metafile to 
the clipboard, the internal representation of the bar code symbol allows a very high resolution 
(which is independent of the adjusted dpi). Thus it is recommended to use vector based image 
formats (EPS, E4C and E1C) whenever possible. However, in the context of certain applications 
(e.g. web applications) it is inevitable to use bitmap images. 

The readability of a bar code can be estimated by looking at the quality watch (see section 7.1, ). 
The quality of a bar code depends on the selected output resolution, the bar code‟s size and its 
content. To ensure an optimal readability, check the option “Optimal Size”. 

6.2.1.2 Module Width 

Larger module widths usually lead to a better readability of a bar code. In practice, for most linear 
bar codes, the module width should never be less than approximately 0.2 mm.  
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6.3 Export to File 

If you want to export a bar code as an image file, select Export ► Export Barcode… from the menu 
or press the keyboard shortcut Ctrl+E. In the Save As dialog choose a filename, select the image 
file type (e.g. “Bitmap (*.bmp)”), and confirm by pressing the Save button. 

The saved image can be imported in your target application (e.g. Microsoft
®
 Word). To import the 

image in Word you would select Insert ► Image ► From File… from the menu. 

► The exported bar code symbol will match the preview in Barcode Studio exactly. 

► To see a list of available image formats, please refer to Appendix C. 

► If the format of the resulting image is a bitmap based file format (see Appendix C), resizing 
of the imported image is not recommended! 

6.4 Copy Barcode to Clipboard 

To copy the current bar code as an image to the clipboard, select Copy Barcode to Clipboard from 
the menu (located in the Export submenu) or from the toolbar. You can also press the keyboard 
shortcut Ctrl+C. 

Then switch to your target application and paste the bar code (e.g. in Microsoft
®
 Word) by pressing 

Ctrl-V (or by selecting Edit ► Insert from the menu). 

► Resizing bar code images may result in a loss of quality. In the worst case resizing a bar 
code image may lead to unreadable bar codes.  

6.5 Copy Metafile to Clipboard 

To copy the current bar code as vector based metafile (EMF) to the clipboard select Copy Metafile 
to Clipboard from the menu (located in the Export submenu) or from the toolbar. You can also press 
the keyboard shortcut Ctrl+M. 

Then switch to your target application and paste the bar code (e.g. in Microsoft
®
 Word) by pressing 

Ctrl-V (or by selecting Edit ► Insert from the menu). 

► Metafiles can only be used on Microsoft Windows. 

► Due to the vector based format you may resize the imported image within your target 
application without heavy losses in readability. 

► The resulting bar codes may differ from the preview in Barcode Studio. The bars in the 
symbol may be enlarged and therefore the font of the human readable text may not fit 
exactly. 

6.6 Export a Series of Bar Codes 

For an automated export of a series of bar code images you can use the Create Sequence function. 

This function is described in chapter 8. 
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7 Barcode Studio User Interface 

7.1 Main Window and Menu 

 
Figure 2: User Interface 

The main window is split into the following areas: 

 Menu (see section 7.2). 

 Toolbar (see section 7.3). 

 Barcode View (see section 7.6). 

 Quality Watch (see section 7.4). 

 Bar Code Settings (see chapter 7). 

 Settings for 2D symbologies (according to selected symbology; see section 7.9) 

 Symbology (see section 7.4). 


















